What’s Vulnerable › Vulnerabilities
CVE-2021-35525
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-28 · updated 2026-06-17
Description
PostSRSd before 1.11 allows a denial of service (subprocess hang) if Postfix sends certain long data fields such as multiple concatenated email addresses. NOTE: the PostSRSd maintainer acknowledges "theoretically, this error should never occur ... I'm not sure if there's a reliable way to trigger this condition by an external attacker, but it is a security bug in PostSRSd nevertheless."
Affected products
- Postsrsd Project Postsrsd: before 1.11 — fixed in 1.11
How to fix
Upgrade to a fixed version: Postsrsd Project Postsrsd 1.11. Check the vendor advisory for mitigations.
References
- https://bugs.gentoo.org/793674
- https://github.com/roehling/postsrsd/commit/077be98d8c8a9847e4ae0c7dc09e7474cbe27db2
- https://github.com/roehling/postsrsd/releases/tag/1.11
- https://security.gentoo.org/glsa/202107-08
- https://bugs.gentoo.org/793674
- https://github.com/roehling/postsrsd/commit/077be98d8c8a9847e4ae0c7dc09e7474cbe27db2
- https://github.com/roehling/postsrsd/releases/tag/1.11
- https://security.gentoo.org/glsa/202107-08
Get alerted when CVE-2021-35525 or the next vulnerability affects your stack