What’s Vulnerable › Vulnerabilities
CVE-2021-3554: Improper Access Control vulnerability in the patchesUpdate API
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-24 · updated 2026-06-17
- Weakness: CWE-284
Description
Improper Access Control vulnerability in the patchesUpdate API as implemented in Bitdefender Endpoint Security Tools for Linux as a relay role allows an attacker to manipulate the remote address used for pulling patches. This issue affects: Bitdefender Endpoint Security Tools for Linux versions prior to 6.6.27.390; versions prior to 7.1.2.33. Bitdefender Unified Endpoint versions prior to 6.2.21.160. Bitdefender GravityZone versions prior to 6.24.1-1.
Affected products
- Bitdefender Endpoint Security Tools: before 6.6.27.390; from 7.0.0.00 before 7.1.2.33 — fixed in 6.6.27.390, 7.1.2.33
- Bitdefender GravityZone: before 6.24.1-1; 6.24.1-1 — fixed in 6.24.1-1
How to fix
Upgrade to a fixed version: Bitdefender Endpoint Security Tools 6.6.27.390, 7.1.2.33; Bitdefender GravityZone 6.24.1-1. Check the vendor advisory for mitigations.
References
- https://www.bitdefender.com/support/security-advisories/improper-access-control-vulnerability-patchesupdate-api-va-9825
- https://www.bitdefender.com/support/security-advisories/improper-access-control-vulnerability-patchesupdate-api-va-9825
Get alerted when CVE-2021-3554 or the next vulnerability affects your stack