What’s Vulnerable › Vulnerabilities
CVE-2021-3559
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-24 · updated 2026-06-17
- Weakness: CWE-119
Description
A flaw was found in libvirt in the virConnectListAllNodeDevices API in versions before 7.0.0. It only affects hosts with a PCI device and driver that supports mediated devices (e.g., GRID driver). This flaw could be used by an unprivileged client with a read-only connection to crash the libvirt daemon by executing the 'nodedev-list' virsh command. The highest threat from this vulnerability is to system availability.
Affected products
- NetApp ONTAP Select Deploy administration utility: all versions
- libvirt: from 6.10.0 before 7.0.0 — fixed in 7.0.0
How to fix
Upgrade to a fixed version: libvirt 7.0.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1962306
- https://security.netapp.com/advisory/ntap-20210706-0006/
- https://bugzilla.redhat.com/show_bug.cgi?id=1962306
- https://security.netapp.com/advisory/ntap-20210706-0006/
Get alerted when CVE-2021-3559 or the next vulnerability affects your stack