What’s Vulnerable › Vulnerabilities
CVE-2021-3560: Red Hat Polkit Incorrect Authorization Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2023-05-12
- EPSS: 23.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-16 · updated 2026-06-17
- Weakness: CWE-863
Description
It was found that polkit could be tricked into bypassing the credential checks for D-Bus requests, elevating the privileges of the requestor to the root user. This flaw could be used by an unprivileged local attacker to, for example, create a new local administrator. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Affected products
- Canonical Ubuntu Linux: 20.04
- Debian Linux: 11.0
- Polkit Project Polkit: before 0.119 — fixed in 0.119
- Red Hat OpenShift Container Platform 4.18: 4.7
- RedHat Virtualization: 4.0
- RedHat Virtualization Host: 4.0
How to fix
Upgrade to a fixed version: Polkit Project Polkit 0.119. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/172836/polkit-Authentication-Bypass.html
- http://packetstormsecurity.com/files/172846/Facebook-Fizz-Denial-Of-Service.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1961710
- https://github.blog/2021-06-10-privilege-escalation-polkit-root-on-linux-with-bug/
- http://packetstormsecurity.com/files/172836/polkit-Authentication-Bypass.html
- http://packetstormsecurity.com/files/172846/Facebook-Fizz-Denial-Of-Service.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1961710
- https://github.blog/2021-06-10-privilege-escalation-polkit-root-on-linux-with-bug/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2021-3560
Get alerted when CVE-2021-3560 or the next vulnerability affects your stack