What’s Vulnerable › Vulnerabilities
CVE-2021-3566
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-05 · updated 2026-06-17
- Weakness: CWE-200
Description
Prior to ffmpeg version 4.3, the tty demuxer did not have a 'read_probe' function assigned to it. By crafting a legitimate "ffconcat" file that references an image, followed by a file the triggers the tty demuxer, the contents of the second file will be copied into the output file verbatim (as long as the `-vcodec copy` option is passed to ffmpeg).
Affected products
- Debian Linux: 9.0
- FFmpeg: before 4.3 — fixed in 4.3
How to fix
Upgrade to a fixed version: FFmpeg 4.3. Check the vendor advisory for mitigations.
References
- https://github.com/FFmpeg/FFmpeg/commit/3bce9e9b3ea35c54bacccc793d7da99ea5157532#diff-74f6b92a0541378ad15de9c29c0a2b0c69881ad9ffc71abe568b88b535e00a7f
- https://lists.debian.org/debian-lts-announce/2021/08/msg00018.html
- https://github.com/FFmpeg/FFmpeg/commit/3bce9e9b3ea35c54bacccc793d7da99ea5157532#diff-74f6b92a0541378ad15de9c29c0a2b0c69881ad9ffc71abe568b88b535e00a7f
- https://lists.debian.org/debian-lts-announce/2021/08/msg00018.html
Get alerted when CVE-2021-3566 or the next vulnerability affects your stack