What’s Vulnerable › Vulnerabilities

CVE-2021-3570

Description

A flaw was found in the ptp4l program of the linuxptp package. A missing length check when forwarding a PTP message between ports allows a remote attacker to cause an information leak, crash, or potentially remote code execution. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. This flaw affects linuxptp versions before 3.1.1, before 2.0.1, before 1.9.3, before 1.8.1, before 1.7.1, before 1.6.1 and before 1.5.1.

Affected products

How to fix

Upgrade to a fixed version: Linuxptp Project Linuxptp 1.5.1, 1.6.1, 1.7.1, 1.8.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-3570 or the next vulnerability affects your stack