What’s Vulnerable › Vulnerabilities
CVE-2021-3583
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-22 · updated 2026-06-17
- Weakness: CWE-20
Description
A flaw was found in Ansible, where a user's controller is vulnerable to template injection. This issue can occur through facts used in the template if the user is trying to put templates in multi-line YAML strings and the facts being handled do not routinely include special template characters. This flaw allows attackers to perform command injection, which discloses sensitive information. The highest threat from this vulnerability is to confidentiality and integrity.
Affected products
- Red Hat Ansible Automation Platform: 1.2
- RedHat Ansible Engine: before 2.9.23 — fixed in 2.9.23
- Tower: before 3.7.0 — fixed in 3.7.0
How to fix
Upgrade to a fixed version: RedHat Ansible Engine 2.9.23; Tower 3.7.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1968412
- https://lists.debian.org/debian-lts-announce/2023/12/msg00018.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1968412
- https://lists.debian.org/debian-lts-announce/2023/12/msg00018.html
Get alerted when CVE-2021-3583 or the next vulnerability affects your stack