What’s Vulnerable › Vulnerabilities
CVE-2021-3589
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-23 · updated 2026-06-17
- Weakness: CWE-306
Description
An authorization flaw was found in Foreman Ansible. An authenticated attacker with certain permissions to create and run Ansible jobs can access hosts through job templates. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Affected products
- Red Hat Satellite 6: 6.0
- theforeman Foreman Ansible: before 7.1.0 — fixed in 7.1.0
How to fix
Upgrade to a fixed version: theforeman Foreman Ansible 7.1.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2021-3589
- https://bugzilla.redhat.com/show_bug.cgi?id=1969265
- https://access.redhat.com/security/cve/CVE-2021-3589
- https://bugzilla.redhat.com/show_bug.cgi?id=1969265
Get alerted when CVE-2021-3589 or the next vulnerability affects your stack