What’s Vulnerable › Vulnerabilities
CVE-2021-35970
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-30 · updated 2026-06-17
- Weakness: CWE-697
Description
Talk 4 in Coral before 4.12.1 allows remote attackers to discover e-mail addresses and other sensitive information via GraphQL because permission checks use an incorrect data type.
Affected products
- Voxmedia Coral Talk: from 4.0.0 before 4.12.1 — fixed in 4.12.1
How to fix
Upgrade to a fixed version: Voxmedia Coral Talk 4.12.1. Check the vendor advisory for mitigations.
References
- https://docs.coralproject.net/coral/api/graphql/#User
- https://github.com/coralproject/talk/compare/v4.12.0...v4.12.1
- https://github.com/coralproject/talk/issues/3600
- https://github.com/coralproject/talk/pull/3599
- https://docs.coralproject.net/coral/api/graphql/#User
- https://github.com/coralproject/talk/compare/v4.12.0...v4.12.1
- https://github.com/coralproject/talk/issues/3600
- https://github.com/coralproject/talk/pull/3599
Get alerted when CVE-2021-35970 or the next vulnerability affects your stack