What’s Vulnerable › Vulnerabilities
CVE-2021-35973
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-30 · updated 2026-06-17
- Weakness: CWE-697
Description
NETGEAR WAC104 devices before 1.0.4.15 are affected by an authentication bypass vulnerability in /usr/sbin/mini_httpd, allowing an unauthenticated attacker to invoke any action by adding the ¤tsetting.htm substring to the HTTP query, a related issue to CVE-2020-27866. This directly allows the attacker to change the web UI password, and eventually to enable debug mode (telnetd) and gain a shell on the device as the admin limited-user account (however, escalation to root is simple because of weak permissions on the /etc/ directory).
Affected products
- NETGEAR Wac104 Firmware: before 1.0.4.15 — fixed in 1.0.4.15
How to fix
Upgrade to a fixed version: NETGEAR Wac104 Firmware 1.0.4.15. Check the vendor advisory for mitigations.
References
- https://gynvael.coldwind.pl/?lang=en&id=736
- https://kb.netgear.com/000063785/Security-Advisory-for-Authentication-Bypass-on-WAC104-PSV-2021-0075
- https://gynvael.coldwind.pl/?lang=en&id=736
- https://kb.netgear.com/000063785/Security-Advisory-for-Authentication-Bypass-on-WAC104-PSV-2021-0075
Get alerted when CVE-2021-35973 or the next vulnerability affects your stack