What’s Vulnerable › Vulnerabilities
CVE-2021-35980: Adobe Acrobat Reader SpellDictionaryExport Path Traversal Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-06 · updated 2026-06-17
- Weakness: CWE-22
Description
Acrobat Reader DC versions 2021.005.20054 (and earlier), 2020.004.30005 (and earlier) and 2017.011.30197 (and earlier) are affected by a Path traversal vulnerability. An unauthenticated attacker could leverage this vulnerability to achieve arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Acrobat for Edge: from 17.011.30180 before 17.011.30199; from 20.001.30005 before 20.004.30006 — fixed in 17.011.30199, 20.004.30006
- Adobe Acrobat DC: from 15.007.20033 before 21.005.20058 — fixed in 21.005.20058
- Adobe Acrobat Reader: from 17.011.30180 before 17.011.30199; from 20.001.30005 before 20.004.30006 — fixed in 17.011.30199, 20.004.30006
- Adobe Acrobat Reader: from 15.007.20033 before 21.005.20058 — fixed in 21.005.20058
How to fix
Upgrade to a fixed version: Adobe Acrobat for Edge 17.011.30199, 20.004.30006; Adobe Acrobat DC 21.005.20058; Adobe Acrobat Reader 17.011.30199, 20.004.30006; Adobe Acrobat Reader 21.005.20058. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/acrobat/apsb21-51.html
- https://helpx.adobe.com/security/products/acrobat/apsb21-51.html
Get alerted when CVE-2021-35980 or the next vulnerability affects your stack