What’s Vulnerable › Vulnerabilities
CVE-2021-3600
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-08 · updated 2026-06-17
- Weakness: CWE-125
Description
It was discovered that the eBPF implementation in the Linux kernel did not properly track bounds information for 32 bit registers when performing div and mod operations. A local attacker could use this to possibly execute arbitrary code.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Fedoraproject Fedora: 34
- Linux kernel: from 4.14.115 before 4.14.308; from 4.15 before 4.19.206; from 4.20 before 5.4.98; from 5.5 before 5.10.16; 5.11-rc1, 5.11-rc2, 5.11-rc3, 5.11-rc4, 5.11-rc5, 5.11-rc6 (+1) — fixed in 4.14.308, 4.19.206, 5.10.16, 5.4.98
- Red Hat Enterprise Linux: 8.0
How to fix
Upgrade to a fixed version: Linux kernel 4.14.308, 4.19.206, 5.10.16, 5.4.98. Check the vendor advisory for mitigations.
References
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3600
- https://git.kernel.org/linus/e88b2c6e5a4d9ce30d75391e4d950da74bb2bd90
- https://ubuntu.com/security/notices/USN-5003-1
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3600
- https://git.kernel.org/linus/e88b2c6e5a4d9ce30d75391e4d950da74bb2bd90
- https://ubuntu.com/security/notices/USN-5003-1
Get alerted when CVE-2021-3600 or the next vulnerability affects your stack