What’s Vulnerable › Vulnerabilities
CVE-2021-36023: Magento Commerce Widgets Update Layout XML Injection Vulnerability Could Lead To Remote Code Execution
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-06 · updated 2026-06-17
- Weakness: CWE-78
Description
Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an XML Injection vulnerability in the Widgets Update Layout. An attacker with admin privileges can trigger a specially crafted script to achieve remote code execution.
Affected products
- Adobe Magento Commerce: before 2.3.7; from 2.4.0 before 2.4.2; 2.3.7, 2.4.2, 2.4.2-p1 — fixed in 2.3.7, 2.4.2
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 2.3.7, 2.4.2. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/magento/apsb21-64.html
- https://helpx.adobe.com/security/products/magento/apsb21-64.html
Get alerted when CVE-2021-36023 or the next vulnerability affects your stack