What’s Vulnerable › Vulnerabilities
CVE-2021-3605
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-25 · updated 2026-06-17
- Weakness: CWE-119
Description
There's a flaw in OpenEXR's rleUncompress functionality in versions prior to 3.0.5. An attacker who is able to submit a crafted file to an application linked with OpenEXR could cause an out-of-bounds read. The greatest risk from this flaw is to application availability.
Affected products
- Debian Linux: 10.0, 11.0
- AcademySoftwareFoundation openexr: before 3.0.5 — fixed in 3.0.5
- Red Hat Enterprise Linux: 8.0
How to fix
Upgrade to a fixed version: AcademySoftwareFoundation openexr 3.0.5. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1970991
- https://lists.debian.org/debian-lts-announce/2022/12/msg00022.html
- https://security.gentoo.org/glsa/202210-31
- https://www.debian.org/security/2022/dsa-5299
- https://bugzilla.redhat.com/show_bug.cgi?id=1970991
- https://lists.debian.org/debian-lts-announce/2022/12/msg00022.html
- https://security.gentoo.org/glsa/202210-31
- https://www.debian.org/security/2022/dsa-5299
Get alerted when CVE-2021-3605 or the next vulnerability affects your stack