What’s Vulnerable › Vulnerabilities
CVE-2021-3606
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-02 · updated 2026-06-17
- Weakness: CWE-427
Description
OpenVPN before version 2.5.3 on Windows allows local users to load arbitrary dynamic loadable libraries via an OpenSSL configuration file if present, which allows the user to run arbitrary code with the same privilege level as the main OpenVPN process (openvpn.exe).
Affected products
- OpenVPN: before 2.5.3 — fixed in 2.5.3
How to fix
Upgrade to a fixed version: OpenVPN 2.5.3. Check the vendor advisory for mitigations.
References
- https://community.openvpn.net/openvpn/wiki/CVE-2021-3606
- https://community.openvpn.net/openvpn/wiki/SecurityAnnouncements
- https://community.openvpn.net/openvpn/wiki/CVE-2021-3606
- https://community.openvpn.net/openvpn/wiki/SecurityAnnouncements
Get alerted when CVE-2021-3606 or the next vulnerability affects your stack