What’s Vulnerable › Vulnerabilities
CVE-2021-3608
- Severity: medium (CVSS 6.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-24 · updated 2026-06-17
- Weakness: CWE-824
Description
A flaw was found in the QEMU implementation of VMWare's paravirtual RDMA device in versions prior to 6.1.0. The issue occurs while handling a "PVRDMA_REG_DSRHIGH" write from the guest and may result in a crash of QEMU or cause undefined behavior due to the access of an uninitialized pointer. The highest threat from this vulnerability is to system availability.
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 34
- QEMU: before 6.1.0 — fixed in 6.1.0
How to fix
Upgrade to a fixed version: QEMU 6.1.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1973383
- https://lists.debian.org/debian-lts-announce/2022/09/msg00008.html
- https://lists.gnu.org/archive/html/qemu-devel/2021-06/msg07926.html
- https://security.gentoo.org/glsa/202208-27
- https://security.netapp.com/advisory/ntap-20220318-0002/
- https://bugzilla.redhat.com/show_bug.cgi?id=1973383
- https://lists.debian.org/debian-lts-announce/2022/09/msg00008.html
- https://lists.gnu.org/archive/html/qemu-devel/2021-06/msg07926.html
- https://security.gentoo.org/glsa/202208-27
- https://security.netapp.com/advisory/ntap-20220318-0002/
Get alerted when CVE-2021-3608 or the next vulnerability affects your stack