What’s Vulnerable › Vulnerabilities
CVE-2021-3610
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-24 · updated 2026-06-17
- Weakness: CWE-125
Description
A heap-based buffer overflow vulnerability was found in ImageMagick in versions prior to 7.0.11-14 in ReadTIFFImage() in coders/tiff.c. This issue is due to an incorrect setting of the pixel array size, which can lead to a crash and segmentation fault.
Affected products
- Fedoraproject Fedora: 34
- ImageMagick: from 6.9.10.88 before 6.9.12-14; from 7.0.0-0 before 7.0.11-14 — fixed in 6.9.12-14, 7.0.11-14
- Red Hat Enterprise Linux: 8.0
How to fix
Upgrade to a fixed version: ImageMagick 6.9.12-14, 7.0.11-14. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/05/29/4
- http://www.openwall.com/lists/oss-security/2023/06/05/1
- https://bugzilla.redhat.com/show_bug.cgi?id=1973689
- https://github.com/ImageMagick/ImageMagick/commit/930ff0d1a9bc42925a7856e9ea53f5fc9f318bf3
- http://www.openwall.com/lists/oss-security/2023/05/29/4
- http://www.openwall.com/lists/oss-security/2023/06/05/1
- https://bugzilla.redhat.com/show_bug.cgi?id=1973689
- https://github.com/ImageMagick/ImageMagick/commit/930ff0d1a9bc42925a7856e9ea53f5fc9f318bf3
- https://github.com/fuzzing2026/CVE-PoCs/tree/main/imagemagick-CVE-2021-3610
Get alerted when CVE-2021-3610 or the next vulnerability affects your stack