What’s Vulnerable › Vulnerabilities
CVE-2021-3611
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-11 · updated 2026-06-17
- Weakness: CWE-119
Description
A stack overflow vulnerability was found in the Intel HD Audio device (intel-hda) of QEMU. A malicious guest could use this flaw to crash the QEMU process on the host, resulting in a denial of service condition. The highest threat from this vulnerability is to system availability. This flaw affects QEMU versions prior to 7.0.0.
Affected products
- QEMU: before 7.0.0 — fixed in 7.0.0
- Red Hat Enterprise Linux: 8.0
How to fix
Upgrade to a fixed version: QEMU 7.0.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1973784
- https://gitlab.com/qemu-project/qemu/-/issues/542
- https://security.gentoo.org/glsa/202208-27
- https://security.netapp.com/advisory/ntap-20220624-0001/
- https://bugzilla.redhat.com/show_bug.cgi?id=1973784
- https://gitlab.com/qemu-project/qemu/-/issues/542
- https://security.gentoo.org/glsa/202208-27
- https://security.netapp.com/advisory/ntap-20220624-0001/
Get alerted when CVE-2021-3611 or the next vulnerability affects your stack