What’s Vulnerable › Vulnerabilities
CVE-2021-36143
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-02 · updated 2026-06-17
- Weakness: CWE-476
Description
ACRN before 2.5 has a hw/pci/virtio/virtio.c vq_endchains NULL Pointer Dereference.
Affected products
- Linux Acrn: before 2.5 — fixed in 2.5
How to fix
Upgrade to a fixed version: Linux Acrn 2.5. Check the vendor advisory for mitigations.
References
- https://github.com/projectacrn/acrn-hypervisor/commit/154fe59531c12b82e26d1b24b5531f5066d224f5
- https://github.com/projectacrn/acrn-hypervisor/commit/154fe59531c12b82e26d1b24b5531f5066d224f5
Get alerted when CVE-2021-36143 or the next vulnerability affects your stack