What’s Vulnerable › Vulnerabilities
CVE-2021-36148
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-02 · updated 2026-06-17
- Weakness: CWE-120
Description
An issue was discovered in ACRN before 2.5. dmar_free_irte in hypervisor/arch/x86/vtd.c allows an irte_alloc_bitmap buffer overflow.
Affected products
- Linux Acrn: before 2.5 — fixed in 2.5
How to fix
Upgrade to a fixed version: Linux Acrn 2.5. Check the vendor advisory for mitigations.
References
- https://github.com/projectacrn/acrn-hypervisor/commit/25c0e3817eb332660dd63d1d4522e63dcc94e79a
- https://github.com/projectacrn/acrn-hypervisor/commit/25c0e3817eb332660dd63d1d4522e63dcc94e79a
Get alerted when CVE-2021-36148 or the next vulnerability affects your stack