What’s Vulnerable › Vulnerabilities
CVE-2021-36160: mod_proxy_uwsgi out of bound read
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 62.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-16 · updated 2026-06-17
- Weakness: CWE-125
Description
A carefully crafted request uri-path can cause mod_proxy_uwsgi to read above the allocated memory and crash (DoS). This issue affects Apache HTTP Server versions 2.4.30 to 2.4.48 (inclusive).
Affected products
- Apache HTTP Server: from 2.4.30 before 2.4.49 — fixed in 2.4.49
- Broadcom Brocade Fabric Operating System Firmware: all versions
- Debian Linux: 9.0, 10.0, 11.0
- Fedoraproject Fedora: 34, 35
- NetApp Cloud Backup: all versions
- Clustered Data ONTAP: all versions
- NetApp StorageGRID: all versions
- Oracle Communications Cloud Native Core Network Function Cloud Native Environment: 1.10.0
- Oracle Corporation Enterprise Manager Base Platform: 13.4.0.0, 13.5.0.0
- Oracle Corporation Oracle HTTP Server: 12.2.1.3.0, 12.2.1.4.0
- Oracle Instantis Enterprisetrack: 17.1, 17.2, 17.3
- Oracle Corporation PeopleSoft Enterprise PT PeopleTools: 8.58
- Oracle Corporation Oracle ZFS Storage Appliance Kit: 8.8
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.49. Check the vendor advisory for mitigations.
References
- http://httpd.apache.org/security/vulnerabilities_24.html
- https://lists.apache.org/thread.html/r2eb200ac1340f69aa22af61ab34780c531d110437910cb9c0ece3b37%40%3Cbugs.httpd.apache.org%3E
- https://lists.apache.org/thread.html/r3925e167d5eb1c75def3750c155d753064e1d34a143028bb32910432%40%3Cusers.httpd.apache.org%3E
- https://lists.apache.org/thread.html/r61fdbfc26ab170f4e6492ef3bd5197c20b862ce156e9d5a54d4b899c%40%3Cusers.httpd.apache.org%3E
- https://lists.apache.org/thread.html/r73260f6ba9fb52e43d860905fc90462ba5a814afda2d011f32bbd41c%40%3Cbugs.httpd.apache.org%3E
- https://lists.apache.org/thread.html/r7f2746e916ed370239bc1a1025e5ebbf345f79df9ea0ea39e44acfbb%40%3Cbugs.httpd.apache.org%3E
- https://lists.apache.org/thread.html/r82838efc5fa6fc4c73986399c9b71573589f78b31846aff5bd9b1697%40%3Cusers.httpd.apache.org%3E
- https://lists.apache.org/thread.html/r82c077663f9759c7df5a6656f925b3ee4f55fcd33c889ba7cd687029%40%3Cusers.httpd.apache.org%3E
- https://lists.apache.org/thread.html/r94a61a1517133a19dcf40016e87454ea86e355d06a0cec4c778530f3%40%3Cbugs.httpd.apache.org%3E
- https://lists.apache.org/thread.html/ra1c05a392587bfe34383dffe1213edc425de8d4afc25b7cefab3e781%40%3Cbugs.httpd.apache.org%3E
- https://lists.apache.org/thread.html/ra87a69d0703d09dc52b86e32b08f8d7327af10acdd5f577a4e82596a%40%3Cbugs.httpd.apache.org%3E
- https://lists.apache.org/thread.html/rb2341c8786d0f9924f5b666e82d8d170b4804f50a523d750551bef1a%40%3Cbugs.httpd.apache.org%3E
Get alerted when CVE-2021-36160 or the next vulnerability affects your stack