What’s Vulnerable › Vulnerabilities
CVE-2021-3618
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-23 · updated 2026-06-17
- Weakness: CWE-295
Description
ALPACA is an application layer protocol content confusion attack, exploiting TLS servers implementing different protocols but using compatible certificates, such as multi-domain or wildcard certificates. A MiTM attacker having access to victim's traffic at the TCP/IP layer can redirect traffic from one subdomain to another, resulting in a valid TLS session. This breaks the authentication of TLS and cross-protocol attacks may be possible where the behavior of one protocol service may compromise the other at the application layer.
Affected products
- Debian Linux: 10.0
- nginx: before 1.21.0 — fixed in 1.21.0
- Fedoraproject Fedora: 33, 34, 35
- Sendmail: before 8.17 — fixed in 8.17
- Vsftpd Project Vsftpd: before 3.0.4 — fixed in 3.0.4
How to fix
Upgrade to a fixed version: nginx 1.21.0; Sendmail 8.17; Vsftpd Project Vsftpd 3.0.4. Check the vendor advisory for mitigations.
References
- https://alpaca-attack.com/
- https://bugzilla.redhat.com/show_bug.cgi?id=1975623
- https://lists.debian.org/debian-lts-announce/2022/11/msg00031.html
- https://alpaca-attack.com/
- https://bugzilla.redhat.com/show_bug.cgi?id=1975623
- https://lists.debian.org/debian-lts-announce/2022/11/msg00031.html
Get alerted when CVE-2021-3618 or the next vulnerability affects your stack