What’s Vulnerable › Vulnerabilities
CVE-2021-3619: Rapid7 Velociraptor Notebooks Authenticated Persistent XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Rapid7 Velociraptor 0.5.9 and prior is vulnerable to a post-authentication persistent cross-site scripting (XSS) issue, where an authenticated user could abuse MIME filetype sniffing to embed executable code on a malicious upload. This issue was fixed in version 0.6.0. Note that login rights to Velociraptor is nearly always reserved for trusted and verified users with IT security backgrounds.
Affected products
- Rapid7 Velociraptor: before 0.6.0 — fixed in 0.6.0
How to fix
Upgrade to a fixed version: Rapid7 Velociraptor 0.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/Velocidex/velociraptor/pull/1118
- https://github.com/Velocidex/velociraptor/releases/tag/v0.6.0
- https://github.com/Velocidex/velociraptor/pull/1118
- https://github.com/Velocidex/velociraptor/releases/tag/v0.6.0
Get alerted when CVE-2021-3619 or the next vulnerability affects your stack