What’s Vulnerable › Vulnerabilities
CVE-2021-36193
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-02 · updated 2026-06-17
- Weakness: CWE-121
Description
Multiple stack-based buffer overflows in the command line interpreter of FortiWeb before 6.4.2 may allow an authenticated attacker to achieve arbitrary code execution via specially crafted commands.
Affected products
- Fortinet FortiWeb: from 5.0.0 before 6.2.6; from 6.3.0 before 6.3.16; from 6.4.0 before 6.4.2 — fixed in 6.2.6, 6.3.16, 6.4.2
How to fix
Upgrade to a fixed version: Fortinet FortiWeb 6.2.6, 6.3.16, 6.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-36193 or the next vulnerability affects your stack