What’s Vulnerable › Vulnerabilities
CVE-2021-3620
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-03 · updated 2026-06-17
- Weakness: CWE-209
Description
A flaw was found in Ansible Engine's ansible-connection module, where sensitive information such as the Ansible user credentials is disclosed by default in the traceback error message. The highest threat from this vulnerability is to confidentiality.
Affected products
- RedHat Ansible Automation Platform Early Access: 2.0
- RedHat Ansible Engine: before 2.9.27 — fixed in 2.9.27
- Red Hat Enterprise Linux: 8.0
- RedHat Enterprise Linux For Power Little Endian: 8.0
- OpenStack: 1, 16.1
- RedHat Virtualization: 4.0
- RedHat Virtualization For Ibm Power Little Endian: 4.0
- RedHat Virtualization Host: 4.0
- RedHat Virtualization Manager: 4.4
How to fix
Upgrade to a fixed version: RedHat Ansible Engine 2.9.27. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1975767
- https://github.com/ansible/ansible/blob/stable-2.9/changelogs/CHANGELOG-v2.9.rst#security-fixes
- https://github.com/ansible/ansible/commit/fe28767970c8ec62aabe493c46b53a5de1e5fac0
- https://lists.debian.org/debian-lts-announce/2023/12/msg00018.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1975767
- https://github.com/ansible/ansible/blob/stable-2.9/changelogs/CHANGELOG-v2.9.rst#security-fixes
- https://github.com/ansible/ansible/commit/fe28767970c8ec62aabe493c46b53a5de1e5fac0
- https://lists.debian.org/debian-lts-announce/2023/12/msg00018.html
Get alerted when CVE-2021-3620 or the next vulnerability affects your stack