What’s Vulnerable › Vulnerabilities
CVE-2021-36204: Insufficiently Protected Credentials in Metasys
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-13 · updated 2026-06-17
- Weakness: CWE-522
Description
Under some circumstances an Insufficiently Protected Credentials vulnerability in Johnson Controls Metasys ADS/ADX/OAS 10 versions prior to 10.1.6 and 11 versions prior to 11.0.3 allows API calls to expose credentials in plain text.
Affected products
- Johnsoncontrols Metasys Application And Data Server: from 10.0 before 10.1.6; from 11.0 before 11.0.3 — fixed in 10.1.6, 11.0.3
- Johnsoncontrols Metasys Extended Application And Data Server: from 10.0 before 10.1.6; from 11.0 before 11.0.3 — fixed in 10.1.6, 11.0.3
- Johnsoncontrols Metasys Open Application Server: from 10.0 before 10.1.6; from 11.0 before 11.0.3 — fixed in 10.1.6, 11.0.3
How to fix
Upgrade to a fixed version: Johnsoncontrols Metasys Application And Data Server 10.1.6, 11.0.3; Johnsoncontrols Metasys Extended Application And Data Server 10.1.6, 11.0.3; Johnsoncontrols Metasys Open Application Server 10.1.6, 11.0.3. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/uscert/ics/advisories/icsa-23-012-06
- https://www.johnsoncontrols.com/cyber-solutions/security-advisories
- https://www.cisa.gov/uscert/ics/advisories/icsa-23-012-06
- https://www.johnsoncontrols.com/cyber-solutions/security-advisories
Get alerted when CVE-2021-36204 or the next vulnerability affects your stack