What’s Vulnerable › Vulnerabilities
CVE-2021-36207: Metasys privilege management
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-29 · updated 2026-06-17
- Weakness: CWE-269
Description
Under certain circumstances improper privilege management in Metasys ADS/ADX/OAS servers versions 10 and 11 could allow an authenticated user to elevate their privileges to administrator.
Affected products
- Johnsoncontrols Metasys Application And Data Server: from 10.0 before 10.1.5; from 11.0 before 11.0.2 — fixed in 10.1.5, 11.0.2
- Johnsoncontrols Metasys Extended Application And Data Server: from 10.0 before 10.1.5; from 11.0 before 11.0.2 — fixed in 10.1.5, 11.0.2
- Johnsoncontrols Metasys Open Application Server: from 10.0 before 10.1.5; from 11.0 before 11.0.2 — fixed in 10.1.5, 11.0.2
How to fix
Upgrade to a fixed version: Johnsoncontrols Metasys Application And Data Server 10.1.5, 11.0.2; Johnsoncontrols Metasys Extended Application And Data Server 10.1.5, 11.0.2; Johnsoncontrols Metasys Open Application Server 10.1.5, 11.0.2. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-118-01
- https://www.johnsoncontrols.com/cyber-solutions/security-advisories
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-118-01
- https://www.johnsoncontrols.com/cyber-solutions/security-advisories
Get alerted when CVE-2021-36207 or the next vulnerability affects your stack