What’s Vulnerable › Vulnerabilities

CVE-2021-3629

Description

A flaw was found in Undertow. A potential security issue in flow control handling by the browser over http/2 may potentially cause overhead or a denial of service in the server. The highest threat from this vulnerability is availability. This flaw affects Undertow versions prior to 2.0.40.Final and prior to 2.2.11.Final.

Affected products

How to fix

Upgrade to a fixed version: Red Hat undertow 2.0.40, 2.2.11; RedHat Wildfly Core 17.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-3629 or the next vulnerability affects your stack