What’s Vulnerable › Vulnerabilities
CVE-2021-36297
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-28 · updated 2026-06-17
- Weakness: CWE-426
Description
SupportAssist Client version 3.8 and 3.9 contains an Untrusted search path vulnerability that allows attackers to load an arbitrary .dll file via .dll planting/hijacking, only by a separate administrative action that is not a default part of the SOSInstallerTool.exe installation for executing arbitrary dll's,
Affected products
- Dell SupportAssist Client Consumer: before 3.9.0 — fixed in 3.9.0
How to fix
Upgrade to a fixed version: Dell SupportAssist Client Consumer 3.9.0. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000191057/dsa-2021-163-dell-supportassist-client-consumer-security-update-for-two-vulnerabilities
- https://www.dell.com/support/kbdoc/en-us/000191057/dsa-2021-163-dell-supportassist-client-consumer-security-update-for-two-vulnerabilities
Get alerted when CVE-2021-36297 or the next vulnerability affects your stack