What’s Vulnerable › Vulnerabilities
CVE-2021-36347
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-25 · updated 2026-06-17
- Weakness: CWE-121
Description
iDRAC9 versions prior to 5.00.20.00 and iDRAC8 versions prior to 2.82.82.82 contain a stack-based buffer overflow vulnerability. An authenticated remote attacker with high privileges could potentially exploit this vulnerability to control process execution and gain access to the iDRAC operating system.
Affected products
- Dell Integrated Dell Remote Access Controller 8: before 2.82.82.82 — fixed in 2.82.82.82
- Dell Integrated Dell Remote Access Controller 9 Firmware: before 5.00.20.00 — fixed in 5.00.20.00
How to fix
Upgrade to a fixed version: Dell Integrated Dell Remote Access Controller 8 2.82.82.82; Dell Integrated Dell Remote Access Controller 9 Firmware 5.00.20.00. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-36347 or the next vulnerability affects your stack