What’s Vulnerable › Vulnerabilities
CVE-2021-36368
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-13 · updated 2026-06-17
- Weakness: CWE-287
Description
An issue was discovered in OpenSSH before 8.9. If a client is using public-key authentication with agent forwarding but without -oLogLevel=verbose, and an attacker has silently modified the server to support the None authentication option, then the user cannot determine whether FIDO authentication is going to confirm that the user wishes to connect to that server, or that the user wishes to allow that server to connect to a different server on the user's behalf. NOTE: the vendor's position is "this is not an authentication bypass, since nothing is being bypassed.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- OpenSSH: before 8.9 — fixed in 8.9
How to fix
Upgrade to a fixed version: OpenSSH 8.9. Check the vendor advisory for mitigations.
References
- https://bugzilla.mindrot.org/show_bug.cgi?id=3316
- https://docs.ssh-mitm.at/trivialauth.html
- https://github.com/openssh/openssh-portable/pull/258
- https://security-tracker.debian.org/tracker/CVE-2021-36368
- https://www.openssh.com/security.html
- https://bugzilla.mindrot.org/show_bug.cgi?id=3316
- https://docs.ssh-mitm.at/trivialauth.html
- https://github.com/openssh/openssh-portable/pull/258
- https://security-tracker.debian.org/tracker/CVE-2021-36368
- https://www.openssh.com/security.html
Get alerted when CVE-2021-36368 or the next vulnerability affects your stack