What’s Vulnerable › Vulnerabilities
CVE-2021-36396
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-06 · updated 2026-06-17
- Weakness: CWE-918
Description
In Moodle, insufficient redirect handling made it possible to blindly bypass cURL blocked hosts/allowed ports restrictions, resulting in a blind SSRF risk.
Affected products
- Moodle: before 3.9.8; from 3.10.0 before 3.10.5; from 3.11.0 before 3.11.1 — fixed in 3.10.5, 3.11.1, 3.9.8
How to fix
Upgrade to a fixed version: Moodle 3.10.5, 3.11.1, 3.9.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-36396 or the next vulnerability affects your stack