What’s Vulnerable › Vulnerabilities
CVE-2021-36401
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-06 · updated 2026-06-17
- Weakness: CWE-79
Description
In Moodle, ID numbers exported in HTML data formats required additional sanitizing to prevent a local stored XSS risk.
Affected products
- Moodle: before 3.9.8; from 3.10.0 before 3.10.5; from 3.11.0 before 3.11.1 — fixed in 3.10.5, 3.11.1, 3.9.8
How to fix
Upgrade to a fixed version: Moodle 3.10.5, 3.11.1, 3.9.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-36401 or the next vulnerability affects your stack