What’s Vulnerable › Vulnerabilities
CVE-2021-3646: Cross-site Scripting (XSS) - Reflected in btcpayserver/btcpayserver
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-10 · updated 2026-06-17
- Weakness: CWE-79
Description
btcpayserver is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- btcpayserver/btcpayserver: before 1.2.3 — fixed in 1.2.3
How to fix
Upgrade to a fixed version: btcpayserver/btcpayserver 1.2.3. Check the vendor advisory for mitigations.
References
- https://github.com/btcpayserver/btcpayserver/commit/fc4e47cec608cc3dba24b19d0145ac69320b975e
- https://huntr.dev/bounties/32e30ecf-31fa-45f6-8552-47250ef0e613
- https://github.com/btcpayserver/btcpayserver/commit/fc4e47cec608cc3dba24b19d0145ac69320b975e
- https://huntr.dev/bounties/32e30ecf-31fa-45f6-8552-47250ef0e613
Get alerted when CVE-2021-3646 or the next vulnerability affects your stack