What’s Vulnerable › Vulnerabilities
CVE-2021-36737: XSS in V3 Demo Portlet
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The input fields of the Apache Pluto UrlTestPortlet are vulnerable to Cross-Site Scripting (XSS) attacks. Users should migrate to version 3.1.1 of the v3-demo-portlet.war artifact
Affected products
- Apache Software Foundation Apache Pluto: before 3.1.1 — fixed in 3.1.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Pluto 3.1.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/x7kt47bf358x8sg9qg02zt0dmdrtow25
- https://lists.apache.org/thread/x7kt47bf358x8sg9qg02zt0dmdrtow25
Get alerted when CVE-2021-36737 or the next vulnerability affects your stack