What’s Vulnerable › Vulnerabilities
CVE-2021-36738: XSS vulnerability in the JSP version of the Apache Pluto Applicant MVCBean CDI portlet
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The input fields in the JSP version of the Apache Pluto Applicant MVCBean CDI portlet are vulnerable to Cross-Site Scripting (XSS) attacks. Users should migrate to version 3.1.1 of the applicant-mvcbean-cdi-jsp-portlet.war artifact
Affected products
- Apache Software Foundation Apache Pluto: before 3.1.1 — fixed in 3.1.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Pluto 3.1.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/11j19v1gjsk7o6o8nch1xrydow9b8lll
- https://lists.apache.org/thread/11j19v1gjsk7o6o8nch1xrydow9b8lll
Get alerted when CVE-2021-36738 or the next vulnerability affects your stack