What’s Vulnerable › Vulnerabilities

CVE-2021-36740

Description

Varnish Cache, with HTTP/2 enabled, allows request smuggling and VCL authorization bypass via a large Content-Length header for a POST request. This affects Varnish Enterprise 6.0.x before 6.0.8r3, and Varnish Cache 5.x and 6.x before 6.5.2, 6.6.x before 6.6.1, and 6.0 LTS before 6.0.8.

Affected products

How to fix

Upgrade to a fixed version: Varnish-Cache Varnish Cache 6.0.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-36740 or the next vulnerability affects your stack