What’s Vulnerable › Vulnerabilities
CVE-2021-36765
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-04 · updated 2026-06-17
- Weakness: CWE-476
Description
In CODESYS EtherNetIP before 4.1.0.0, specific EtherNet/IP requests may cause a null pointer dereference in the downloaded vulnerable EtherNet/IP stack that is executed by the CODESYS Control runtime system.
Affected products
- CODESYS Ethernetip: before 4.1.0.0 — fixed in 4.1.0.0
How to fix
Upgrade to a fixed version: CODESYS Ethernetip 4.1.0.0. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=16806&token=3b0c51de5a6e35bccbb413ddaaa56551ca5490f6&download=
- https://customers.codesys.com/index.php?eID=dumpFile&t=f&f=16806&token=3b0c51de5a6e35bccbb413ddaaa56551ca5490f6&download=
Get alerted when CVE-2021-36765 or the next vulnerability affects your stack