What’s Vulnerable › Vulnerabilities
CVE-2021-3677
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-02 · updated 2026-06-17
- Weakness: CWE-200
Description
A flaw was found in postgresql. A purpose-crafted query can read arbitrary bytes of server memory. In the default configuration, any authenticated database user can complete this attack at will. The attack does not require the ability to create objects. If server settings include max_worker_processes=0, the known versions of this attack are infeasible. However, undiscovered variants of the attack may be independent of that setting.
Affected products
- Fedoraproject Fedora: 34
- PostgreSQL: from 11.0 before 11.13; from 12.0 before 12.8; from 13.0 before 13.4 — fixed in 11.13, 12.8, 13.4
- Red Hat Enterprise Linux: 8.0
- RedHat Enterprise Linux For Ibm Z Systems: 8.0
- RedHat Enterprise Linux For Power Little Endian: 8.0
- RedHat Software Collections: 1.0
- RedHat Virtualization: 4.0
How to fix
Upgrade to a fixed version: PostgreSQL 11.13, 12.8, 13.4. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2001857
- https://security.gentoo.org/glsa/202211-04
- https://security.netapp.com/advisory/ntap-20220407-0008/
- https://www.postgresql.org/support/security/CVE-2021-3677/
- https://bugzilla.redhat.com/show_bug.cgi?id=2001857
- https://security.gentoo.org/glsa/202211-04
- https://security.netapp.com/advisory/ntap-20220407-0008/
- https://www.postgresql.org/support/security/CVE-2021-3677/
Get alerted when CVE-2021-3677 or the next vulnerability affects your stack