What’s Vulnerable › Vulnerabilities

CVE-2021-36770

Description

Encode.pm, as distributed in Perl through 5.34.0, allows local users to gain privileges via a Trojan horse Encode::ConfigLocal library (in the current working directory) that preempts dynamic module loading. Exploitation requires an unusual configuration, and certain 2021 versions of Encode.pm (3.05 through 3.11). This issue occurs because the || operator evaluates @INC in a scalar context, and thus @INC has only an integer value.

Affected products

How to fix

Upgrade to a fixed version: P5-Encode Project P5-Encode 3.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-36770 or the next vulnerability affects your stack