What’s Vulnerable › Vulnerabilities
CVE-2021-36778: Exposure of repository credentials to external third-party sources
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-02 · updated 2026-06-17
- Weakness: CWE-863
Description
A Incorrect Authorization vulnerability in SUSE Rancher allows administrators of third-party repositories to gather credentials that are sent to their servers. This issue affects: SUSE Rancher Rancher versions prior to 2.5.12; Rancher versions prior to 2.6.3.
Affected products
- SUSE Rancher: before 2.5.12; from 2.6.0 before 2.6.3 — fixed in 2.5.12, 2.6.3
How to fix
Upgrade to a fixed version: SUSE Rancher 2.5.12, 2.6.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-36778 or the next vulnerability affects your stack