What’s Vulnerable › Vulnerabilities
CVE-2021-36847: WordPress Webba Booking plugin <= 4.2.21 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Authenticated (admin+) Stored Cross-Site Scripting (XSS) vulnerability in WebbaPlugins Webba Booking plugin <= 4.2.21 at WordPress.
Affected products
- webba-agency Easy Appointment Booking & Scheduling System – Webba Booking Calendar: before 4.2.22 — fixed in 4.2.22
How to fix
Upgrade to a fixed version: webba-agency Easy Appointment Booking & Scheduling System – Webba Booking Calendar 4.2.22. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/webba-booking-lite/wordpress-webba-booking-plugin-4-2-21-authenticated-stored-cross-site-scripting-xss-vulnerability
- https://wordpress.org/plugins/webba-booking-lite/#developers
- https://patchstack.com/database/vulnerability/webba-booking-lite/wordpress-webba-booking-plugin-4-2-21-authenticated-stored-cross-site-scripting-xss-vulnerability
- https://wordpress.org/plugins/webba-booking-lite/#developers
Get alerted when CVE-2021-36847 or the next vulnerability affects your stack