What’s Vulnerable › Vulnerabilities
CVE-2021-36889: WordPress tarteaucitron.js – Cookies legislation & GDPR plugin <= 1.6 - Multiple Stored Authenticated Cross-Site Scripting (XSS) vulnerabilities
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple Stored Authenticated Cross-Site Scripting (XSS) vulnerabilities were discovered in tarteaucitron.js – Cookies legislation & GDPR WordPress plugin (versions <= 1.6).
Affected products
- tarteaucitron.js – Cookies legislation & GDPR (WordPress plugin): before 1.6.1 — fixed in 1.6.1
How to fix
Upgrade to a fixed version: tarteaucitron.js – Cookies legislation & GDPR (WordPress plugin) 1.6.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/tarteaucitronjs/wordpress-tarteaucitron-js-cookies-legislation-gdpr-plugin-1-6-multiple-stored-authenticated-cross-site-scripting-xss-vulnerabilities
- https://wordpress.org/plugins/tarteaucitronjs/#developers
- https://patchstack.com/database/vulnerability/tarteaucitronjs/wordpress-tarteaucitron-js-cookies-legislation-gdpr-plugin-1-6-multiple-stored-authenticated-cross-site-scripting-xss-vulnerabilities
- https://wordpress.org/plugins/tarteaucitronjs/#developers
Get alerted when CVE-2021-36889 or the next vulnerability affects your stack