What’s Vulnerable › Vulnerabilities
CVE-2021-36947: Windows Print Spooler Remote Code Execution Vulnerability
- Severity: medium (CVSS 6.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-12 · updated 2026-08-10
Description
Windows Print Spooler Remote Code Execution Vulnerability
Affected products
- Microsoft Windows 10 Version 1607: 20h2, 21h1, 1607, 1809, 1909, 2004
- Microsoft Windows 7: all versions
- Microsoft Windows 8.1: all versions
- Microsoft Windows RT 8.1: all versions
- Microsoft Windows Server 2008: r2-sp1
- Microsoft Windows Server 2012: r2
- Microsoft Windows Server 2016: 20h2, 2004
- Microsoft Windows Server 2019: all versions
- Microsoft Windows 10 Version 1507: from 10.0.10240.0 before 10.0.10240.19022 — fixed in 10.0.10240.19022
- Microsoft Windows 10 1607: from 10.0.14393.0 before 10.0.14393.4583 — fixed in 10.0.14393.4583
- Microsoft Windows 10: from 10.0.17763.0 before 10.0.17763.2114 — fixed in 10.0.17763.2114
- Microsoft Windows 10 1909: from 10.0.0 before 10.0.18363.1734 — fixed in 10.0.18363.1734
- Microsoft Windows 10 2004: from 10.0.0 before 10.0.19041.1165 — fixed in 10.0.19041.1165
- Microsoft Windows 10 20H2: from 10.0.0 before 10.0.19042.1165 — fixed in 10.0.19042.1165
- Microsoft Windows 10 21H1: from 10.0.0 before 10.0.19043.1165 — fixed in 10.0.19043.1165
- Microsoft Windows 7: from 6.1.0 before 6.1.7601.25685 — fixed in 6.1.7601.25685
- Microsoft Windows 7 Service Pack 1: from 6.1.0 before 6.1.7601.25685 — fixed in 6.1.7601.25685
- Microsoft Windows 8.1: from 6.3.0 before 6.3.9600.20094 — fixed in 6.3.9600.20094
- Microsoft Windows Server 2008 R2 Service Pack 1: from 6.1.7601.0 before 6.1.7601.25685 — fixed in 6.1.7601.25685
- Microsoft Windows Server 2008 Service Pack 2: from 6.0.6003.0 before 6.0.6003.21192 — fixed in 6.0.6003.21192
- Microsoft Windows Server 2012: from 6.2.9200.0 before 6.2.9200.23435 — fixed in 6.2.9200.23435
- Microsoft Windows Server 2012 R2: from 6.3.9600.0 before 6.3.9600.20094 — fixed in 6.3.9600.20094
- Microsoft Windows Server 2016: from 10.0.14393.0 before 10.0.14393.4583 — fixed in 10.0.14393.4583
- Microsoft Windows Server 2019: from 10.0.17763.0 before 10.0.17763.2114 — fixed in 10.0.17763.2114
- Microsoft Windows Server version 2004: from 10.0.0 before 10.0.19041.1165 — fixed in 10.0.19041.1165
- Microsoft Windows Server version 20H2: from 10.0.0 before 10.0.19042.1165 — fixed in 10.0.19042.1165
How to fix
Upgrade to a fixed version: Microsoft Windows 10 Version 1507 10.0.10240.19022; Microsoft Windows 10 1607 10.0.14393.4583; Microsoft Windows 10 10.0.17763.2114; Microsoft Windows 10 1909 10.0.18363.1734; Microsoft Windows 10 2004 10.0.19041.1165; Microsoft Windows 10 20H2 10.0.19042.1165; Microsoft Windows 10 21H1 10.0.19043.1165; Microsoft Windows 7 6.1.7601.25685; Microsoft Windows 7 Service Pack 1 6.1.7601.25685; Microsoft Windows 8.1 6.3.9600.20094; Microsoft Windows Server 2008 R2 Service Pack 1 6.1.7601.25685; Microsoft Windows Server 2008 Service Pack 2 6.0.6003.21192. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2021-36947
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2021-36947
Get alerted when CVE-2021-36947 or the next vulnerability affects your stack