What’s Vulnerable › Vulnerabilities
CVE-2021-3697
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-06 · updated 2026-06-17
- Weakness: CWE-787
Description
A crafted JPEG image may lead the JPEG reader to underflow its data pointer, allowing user-controlled data to be written in heap. To a successful to be performed the attacker needs to perform some triage over the heap layout and craft an image with a malicious format and payload. This vulnerability can lead to data corruption and eventual code execution or secure boot circumvention. This flaw affects grub2 versions prior grub-2.12.
Affected products
- grub2: from 2.00 before 2.12 — fixed in 2.12
- RedHat Codeready Linux Builder: all versions
- RedHat Developer Tools: 1.0
- Red Hat Enterprise Linux: 8.0, 8.1, 8.4, 9.0
- RedHat Enterprise Linux Eus: 8.2, 8.4, 8.6, 9.0
- RedHat Enterprise Linux For Power Little Endian: 8.0, 9.0
- RedHat Enterprise Linux For Power Little Endian Eus: 8.2, 8.4, 8.6, 9.0
- RedHat Enterprise Linux Server Aus: 8.2, 8.4, 8.6
- RedHat Enterprise Linux Server For Power Little Endian Update Services For Sap Solutions: 8.1, 8.2, 8.4, 8.6, 9.0
- RedHat Enterprise Linux Server Tus: 8.2, 8.4, 8.6
- Openshift: 3.0
- Red Hat OpenShift Container Platform 4.18: 4.6, 4.9, 4.10
How to fix
Upgrade to a fixed version: grub2 2.12. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1991687
- https://security.gentoo.org/glsa/202209-12
- https://security.netapp.com/advisory/ntap-20220930-0001/
- https://bugzilla.redhat.com/show_bug.cgi?id=1991687
- https://security.gentoo.org/glsa/202209-12
- https://security.netapp.com/advisory/ntap-20220930-0001/
Get alerted when CVE-2021-3697 or the next vulnerability affects your stack