What’s Vulnerable › Vulnerabilities
CVE-2021-3711: SM2 Decryption Buffer Overflow
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 87.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-08-24 · updated 2026-10-08
- Weakness: CWE-120
Description
In order to decrypt SM2 encrypted data an application is expected to call the API function EVP_PKEY_decrypt(). Typically an application will call this function twice. The first time, on entry, the "out" parameter can be NULL and, on exit, the "outlen" parameter is populated with the buffer size required to hold the decrypted plaintext. The application can then allocate a sufficiently sized buffer and call EVP_PKEY_decrypt() again, but this time passing a non-NULL value for the "out" parameter. A bug in the implementation of the SM2 decryption code means that the calculation of the buffer size required to hold the plaintext returned by the first call to EVP_PKEY_decrypt() can be smaller than the actual size required by the second call. This can lead to a buffer overflow when EVP_PKEY_decrypt() is called by the application a second time with a buffer that is too small. A malicious attacker who is able present SM2 content for decryption to an application could cause attacker chosen data to overflow the buffer by up to a maximum of 62 bytes altering the contents of other data held after the buffer, possibly changing application behaviour or causing the application to crash. The location of the buffer is application dependent but is typically heap allocated. Fixed in OpenSSL 1.1.1l (Affected 1.1.1-1.1.1k).
Affected products
- Debian Linux: 10.0, 11.0
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: all versions
- Clustered Data ONTAP: all versions
- NetApp Clustered Data Ontap Antivirus Connector: all versions
- E-Series SANtricity OS Controller Software 11.x: from 11.0 through 11.50.2
- NetApp Hci Management Node: all versions
- NetApp Manageability Software Development Kit: all versions
- OnCommand Insight: all versions
- NetApp OnCommand Workflow Automation: all versions
- NetApp Santricity Smi-S Provider: all versions
- NetApp SnapCenter: all versions
- NetApp Solidfire: all versions
- NetApp Storage Encryption: all versions
- OpenSSL: from 1.1.1 before 1.1.1l — fixed in 1.1.1l
- Oracle Communications Cloud Native Core Security Edge Protection Proxy: 1.7.0
- Oracle Communications Cloud Native Core Unified Data Repository: 1.15.0
- Oracle Corporation Communications Session Border Controller: 8.4, 9.0
- Oracle Communications Unified Session Manager: 8.2.5, 8.4.5
- Oracle Corporation Enterprise Communications Broker: 3.2.0, 3.3.0
- Oracle Corporation Enterprise Session Border Controller: 8.4, 9.0
- Oracle Corporation Oracle Essbase: before 11.1.2.4.47; from 21.1 before 21.3 — fixed in 11.1.2.4.47, 21.3
- Oracle Health Sciences Inform Publisher: 6.2.1.1, 6.3.1.1
- Oracle Corporation JD Edwards EnterpriseOne Tools: before 9.2.6.3 — fixed in 9.2.6.3
- Oracle Jd Edwards World Security: a9.4
- Oracle Mysql Connectors: through 8.0.27
- Oracle Corporation MySQL Enterprise Monitor: through 8.0.25
- MySQL Server: from 5.7.0 through 5.7.35; from 8.0.0 through 8.0.26
- Oracle Corporation PeopleSoft Enterprise PT PeopleTools: 8.57, 8.58, 8.59
- Oracle Corporation Oracle ZFS Storage Appliance Kit: 8.8
- Tenable Nessus Network Monitor: through 5.13.1
How to fix
Upgrade to a fixed version: OpenSSL 1.1.1l; Oracle Corporation Oracle Essbase 11.1.2.4.47, 21.3; Oracle Corporation JD Edwards EnterpriseOne Tools 9.2.6.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2021/08/26/2
- https://cert-portal.siemens.com/productcert/pdf/ssa-389290.pdf
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=59f5e75f3bced8fc0e130d72a3f582cf7b480b46
- https://lists.apache.org/thread.html/r18995de860f0e63635f3008fd2a6aca82394249476d21691e7c59c9e%40%3Cdev.tomcat.apache.org%3E
- https://lists.apache.org/thread.html/rad5d9f83f0d11fb3f8bb148d179b8a9ad7c6a17f18d70e5805a713d1%40%3Cdev.tomcat.apache.org%3E
- https://security.gentoo.org/glsa/202209-02
- https://security.gentoo.org/glsa/202210-02
- https://security.netapp.com/advisory/ntap-20210827-0010/
- https://security.netapp.com/advisory/ntap-20211022-0003/
- https://security.netapp.com/advisory/ntap-20240621-0006/
- https://www.debian.org/security/2021/dsa-4963
- https://www.openssl.org/news/secadv/20210824.txt
Get alerted when CVE-2021-3711 or the next vulnerability affects your stack