What’s Vulnerable › Vulnerabilities
CVE-2021-3715
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-02 · updated 2026-06-17
- Weakness: CWE-416
Description
A flaw was found in the "Routing decision" classifier in the Linux kernel's Traffic Control networking subsystem in the way it handled changing of classification filters, leading to a use-after-free condition. This flaw allows unprivileged local users to escalate their privileges on the system. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.
Affected products
- Linux kernel: from 3.18 before 4.4.218; from 4.5 before 4.9.218; from 4.10 before 4.14.175; from 4.15 before 4.19.114; from 4.20 before 5.4.29; from 5.5.0 before 5.5.14 — fixed in 4.14.175, 4.19.114, 4.4.218, 4.9.218, 5.4.29, 5.5.14
How to fix
Upgrade to a fixed version: Linux kernel 4.14.175, 4.19.114, 4.4.218, 4.9.218. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=ef299cc3fa1a9e1288665a9fdc8bff55629fd359
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=ef299cc3fa1a9e1288665a9fdc8bff55629fd359
Get alerted when CVE-2021-3715 or the next vulnerability affects your stack