What’s Vulnerable › Vulnerabilities
CVE-2021-37155
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-21 · updated 2026-06-17
Description
wolfSSL 4.6.x through 4.7.x before 4.8.0 does not produce a failure outcome when the serial number in an OCSP request differs from the serial number in the OCSP response.
Affected products
- wolfSSL: from 4.6.0 before 4.8.0 — fixed in 4.8.0
How to fix
Upgrade to a fixed version: wolfSSL 4.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/wolfSSL/wolfssl/pull/3990
- https://github.com/wolfSSL/wolfssl/releases/tag/v4.8.0-stable
- https://github.com/wolfSSL/wolfssl/pull/3990
- https://github.com/wolfSSL/wolfssl/releases/tag/v4.8.0-stable
Get alerted when CVE-2021-37155 or the next vulnerability affects your stack