What’s Vulnerable › Vulnerabilities
CVE-2021-37322
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-18 · updated 2026-06-17
- Weakness: CWE-416
Description
GCC c++filt v2.26 was discovered to contain a use-after-free vulnerability via the component cplus-dem.c.
Affected products
- GNU Binutils: before 2.32 — fixed in 2.32
- GNU GCC: before 10.1 — fixed in 10.1
How to fix
Upgrade to a fixed version: GNU Binutils 2.32; GNU GCC 10.1. Check the vendor advisory for mitigations.
References
- https://gcc.gnu.org/bugzilla/show_bug.cgi?id=99188
- https://gcc.gnu.org/bugzilla/show_bug.cgi?id=99188
Get alerted when CVE-2021-37322 or the next vulnerability affects your stack