What’s Vulnerable › Vulnerabilities

CVE-2021-3746

Description

A flaw was found in the libtpms code that may cause access beyond the boundary of internal buffers. The vulnerability is triggered by specially-crafted TPM2 command packets that then trigger the issue when the state of the TPM2's volatile state is written. The highest threat from this vulnerability is to system availability. This issue affects libtpms versions before 0.8.5, before 0.7.9 and before 0.6.6.

Affected products

How to fix

Upgrade to a fixed version: stefanberger libtpms 0.6.6, 0.7.9, 0.8.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-3746 or the next vulnerability affects your stack